As I'm sure you're aware, this week researchers revealed that Intel, ARM, and AMD had discovered gaps in the security system in their central processing units. While there wasn't much information about at the time, Apple confirmed yesterday that both Mac and iOS devices are affected, but they're already working on a patch.

The security flaws, known as Meltdown (rogue data cache load) and Spectre (bounds check bypass), affect a wide range of devices including Mac and iOS products. Though the fault is applicable to nearly all modern devices, Apple has stated that there are no known exploits affecting customers at the moment.

"Since exploiting many of these issues requires a malicious app to be loaded on your Mac or iOS device, we recommend downloading software only from trusted sources such as the App Store," it's suggested on the blog post.

Though it is a concern, Apple has already released mitigations in iOS 11.2, macOS 10.13.2, and tvOS 11.2 to help protect against Meltdown, though Apple Watch isn't affected by this particular flaw.

A guard against Spectre will hopefully be launching for Safari in the next couple of days, so keep your devices updated, including your search engines, and don't download anything you shouldn't be.

Read more right here.